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Chapter 1: Introduction 

1.1 Purpose 
 
The purpose of this document is to provide a Quide Guide for customers who are using MoCo for direct 
marketing and customer relationship management (CRM). 
 

1.2 Target Audience 
 
The target audiences of this document are all customers who will be using MoCo to perform direct marketing 
and/or CRM. This includes all sole proprietors, marketeers, small business owners, retailers, spa and beauty 
centre operators, restaurant owners, etc. 
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Chapter 2: Client Database Management 

2.1 Export Address Book to file 
 
The entire address book can be exported to either a csv (comma-separated values) file or a tab-delimetered file. 
Both types of files can be openned by Microsoft Excel. You can choose which field within the database to 
export out. 
 
To Export Address Book, 
 
Step 1: From the File menu, click on the Export Address Book 
 
Step 2: On the Export Address Book dialog, check the individual field name checkbox to select the export 
content. Click on the Browse button to select the location and file name of the saved file.  
 
Step 3: Select the type of output file by choosing the delimeter type. You can choose either “Comma” or “Tab”.  
 
Step 4: If you wish to include contact group information in the exported file, checked the “Include contact group 
information” option.  
 
Step 5: Click Export button to complete operation. 
 

2.1.1 Open Exported File using MS Excel 
 
To open the exported file in MS Excel: 
 
Step 1: Open Microsoft Excel. 
 
Step 2: Click “Open” under the “File” menu. A dialog box will be displayed for you to select the file to open. 
 

 
 
Step 3: Select the file and click “Open”. You will see a warning message box as below. Click “Ok”. 
 

 
 
Step 4: You shall see the “Text Import Wizard – Step 1 of 3” dialog box as shown below. Make sure the 
“Delimited” option is selected. Click “Next” button. 
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Step 5: You shall see the “Text Import Wizard – Step 2 of 3” box. Make sure the “Tab” and “Comma” options 
are selected. Click “Next” button. 
 

 
 
Step 6 : You shall now see the “Text Import Wizard – Step 3 of 3” box. Click on the column that represent the 
mobile phone numbers, and then select “Text” option under the “Column data format” selection.  
 

 
 

Step 7: Click “Finish” button. The exported file shall be successfully loaded into Microsoft Excel. You can now 
save it into MS Excel format. 
 

2.2 Import contacts into Address Book 
 
You can import contacts information into MoCo’s Address Book. The import file can be either in csv (comma-
separated-values) format, or a tab-delimetered file, or a MS Excel file (*.xls). 
 
MoCo’s import function is extremely user friendly. You will be able to assign any column to import a specified 
field in MoCo’s address book. There is no fixed structure for importing data. 
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2.2.1 Prepare Import File (csv/txt) from existing database 
 
To prepare import file (csv/txt) from your existing Microsoft Excel spreadsheet,  
 
Step 1: From the File menu, select “Save As …” option. 
 
Step 2: A “Save As” dialog box will appear.  
 

 
 
Step 3: Key in the file name to be saved and select the type of file to be saved. For csv file, select “CSV 
(comma-delimited) (*.csv)” as the file type. For tab-delimited file, select “Text (Tab-delimited) (*.txt)” as the 
file type.  
 
Step 4: Click “Save” button. The below warning box may appear. Just click “Yes” button. 
 

 
 
Step 5: The csv / txt file is saved successfully. Close the MS Excel application. 
 

2.2.2 Prepare Import File (MS Excel) from existing database 
 
To directly import the address book from a MS Excel sheet, you need to convert the “Mobile Number” field 
(and whatever number fields you have in your database) into a Text field: 
 
Step 1: Open the existing excel file using Microsoft Excel. A sample of the excel file is shown below: 
 

 
 
Step 2: Convert column B (“Raw Mobile”) into TEXT: 
 
2a. Highlight the column (in this case, column B) to be converted. 
 
2b. Select from menu, “Data -> Text to Columns …” option. 
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2c. The dialog box shown below will be displayed. Click the “Next” button. 
 

 
 
2d. The dialog box shown below will be displayed. Click the “Next” button again. 
 

 
 
2e. The dialog box shown below will be displayed. Select “Text” and click “Finish” button. 
 

 
 
 
 
 
 
 
 
 
 
 
 

 - 7 - 



2.2.3 Configure type of Import file 
 
Before importing the Address Book, you need to select the type of import file that MoCo needs to import.  
 
Step 1: At the MoCo software, select “Configuration Settings”. A dialog box as shown below will appear. 
 

 
 
Step 2: Under “Format for importing address book”, select the type of import file you are going to import into 
MoCo’s address book. For MS Excel file, you will need to specify the SpreadSheet name also. 
 
Step 3: Click “OK” button. 
 
 

2.2.4 Import csv/txt/excel file into MoCo 
 
To import from csv file into address book, 
 
Step 1: From the File menu, click on the Import Address Book 
 
Step 2: From the Open dialog box, select the csv or txt file to import into the database. Click “Open” button. 
 

 
 
Step 3: On the Import Address Book dialog, match and select the correct field of each column. If you do not 
select a field name above the column, that particular column will not be imported. 
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Step 4: If one of the column of your database contains the name of the contact group, you can select the option 
“Contact Group” for that column. For contacts who are members of multiple contact groups, the contact group 
names are separated by semicolons within the column. 
 

 
 
Step 5: Click Import button to start importing. 
 
Step 6: A dialog box as shown below will appear, displaying the contacts that are imported successfully and 
those that failed.  
 

 
 
Step 7: To save result of the import process, click “Save Result”. The result is saved into a text document. 
 
Step 8: To proceed with the import process, click “Proceed” button. To abort the import process, click “Cancel” 
button. 
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Chapter 3: Creating Templates 
 
MoCo’s Template Editor allows user to create reusable SMS messages. Frequently used SMS can be saved as 
template and recalled when needed. User will be able to access the created template by right-clicking of the 
mouse button in all “Message” text boxes, and then choosing from the options “Insert Template” or “Append 
Template” to include a template into the message. 
 
To add a new template,  
 

Step 1: Click on  button to clear Template Information area. 
 
Step 2: Enter template information (template name and content) into respective fields.  
 

 
 

Step 3: Click on  to save template. 
 
When a template is created successfully, the template name will appear on the List of Templates box. 
 
 

3.1 Message Tags 
 
MoCo supports the use of “Message Tags” for creating dynamic message content. 
 

 
 
You can insert message tags into templates by right-clicking of the mouse, and then select “Insert Message Tag” 
to insert the appropriate message tags. 
 
Currently, MoCo supports the use of the following message tags: 
• Recipient’s Name – This tag shall be used to insert the name of individual recipients at the time of sending. 
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• Recipient’s Number – This tag shall be used to insert the mobile phone number of individual recipients at 
the time of sending. 

• Originator’s Name – This tag is only used in the “Forward to selected Recipients” action of the “Automatic 
Response System”. It shall insert the name of the originator of SMS into the message. 

• Originator’s Number – This tag is only used in the “Forward to selected Recipients” action of the 
“Automatic Response System”. It shall insert the mobile number of the originator of SMS into the message. 

• Specific Date – This tag is only used in the Scheduler. It shall insert the specific date of the scheduled SMS 
sending into the message. 

• Specific Time – This tag is only used in the Scheduler. It shall insert the specific time of the scheduled SMS 
sending into the message. 

• Appointment Date – This tag is only used in the Appointment Book. It shall insert the appointment date into 
the message. 

• Appointment Time – This tag is only used in the Appointment Book. It shall insert the appointment time 
into the message. 

• Appointment Name – This tag is only used in the Appointment Book. It shall insert the appointment name 
into the message. 
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Chapter 4: Customer Relationship Management (CRM) 
 
MoCo’s Event Manager allows user to create periodic event to send SMS. With Event Manager, greeting 
messages like Birthday, New Year, Christmas and Anniversary can be created and SMS will be send 
automatically once the date is reached. 
 

4.1 Add new Event 

4.1.1 Add new Event based on Specific Date 
 
To add a new event based on Specific Date,  
 

Step 1: Click on  button to clear Event information area. 
 
Step 2: Enter event information into respective fields.  
 

 
 

• Event Name – Enter a name for the event. 
• Message Content – The SMS content to be sent when the event’s date is reached. You can use template 

and message tags here also. 
• Message Type – Indicate the type of message to be sent. Options are “Normal”, “8-Bit Data” and 

“Unicode (Chinese Text)”.  
• Event Status – Suspend or Active. If event status is “Suspend”, sms will not be sent even if the event’s 

date is reached. 
• Specific Date – The date at which the sms will be sent.  
• Period – Annually or Monthly. In above example, if “Annually” is selected, the sms will be sent out 

every year on 31st December. If “Monthly” is selected, the sms will be sent out on the 31st of every 
month. 

• Preferred time to SMS – Indicate the preferred time of the day to send out sms. SMS will only be sent 
out when both the event’s date and the preferred time is reached. 

• Everyone in Address Book – Select this option if the sms is to be sent to everyone within the Address 
Book. 

• Selected Recipients – Select this option if you only want to send event sms to selected recipients. You 
can use the Advanced Search Engine for selection of recipients, or simply select from a list of contacts 
and/or contact groups. 

  

Step 3: Click on  to save event. 
 
When an event is created successfully, the event name will appear  
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on the List of Events box. 
 

4.1.2 Add new Event based on Address Book 
 
To add a new event based on Address Book,  
 

Step 1: Click on  button to clear Event information area. 
 
Step 2: Enter event information into respective fields.  
 

 
 

• Event Name – Enter a name for the event. 
• Message Content – The SMS content to be sent when the event’s date is reached. You can use template 

and message tags here also. 
• Message Type – Indicate the type of message to be sent. Options are “Normal”, “8-Bit Data” and 

“Unicode (Chinese Text)”.  
• Event Status – Suspend or Active. If event status is “Suspend”, sms will not be sent even if the event’s 

date is reached. 
• Address Book Field – Select the field of the Address Book on which the event is based. In the above 

example, the event is based on the “Date of Birth” field of the Address Book.  
• Period – Annually or Monthly. In above example, if “Annually” is selected, sms will be sent out every 

year on the birthday of the customer. If “Monthly” is selected, sms will be sent out on the day of  the 
“Date of Birth” every month. 

• Preferred time to SMS – Indicate the preferred time of the day to send out sms. SMS will only be sent 
out when both the event’s date and the preferred time is reached. 

• Everyone in Address Book – Select this option if the sms is to be sent to everyone within the Address 
Book. 

• Selected Recipients – Select this option if you only want to send event sms to selected recipients. You 
can use the Advanced Search Engine for selection of recipients, or simply select from a list of contacts 
and/or contact groups. 
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Chapter 5: Targeted Direct Marketing 
 
MoCo can be used to targeted direct marketing, that is, broadcasting sms to customers who most probably are 
interested in your products / services. 
  
To perform targeted direct marketing, 
 

Step 1: From “Tools” menu, select “Send SMS” option. You can also click the  button on the toolbar 
alternatively. 
 
 
Step 2: A dialog box as shown below will appear. Type in the message you want to send in the message box 
provided. The text on the left indicates the number of characters within the message. For “Normal Text” 
message, one SMS allows 160 characters. For “Unicode (Chinese Text)” message, one SMS allows 70 
characters. If the number of characters exceeds the limit, it shall be broken into multiple SMSes before sending 
out. 
 

 
 
Step 3: Alternatively, you can select from a list of message templates by right-clicking the mouse inside the 
message box. A context box will appear. Move the mouse to “Insert Template” option to select a pre-defined 
message template. 
 

 
 

Step 4: Select the Message Type of the message you wish to send. If your message contains chinese text, you 
must select “Unicode (Chinese Text)” option. 
 
Step 5: Click the “Advanced” button. 
 
Step 6: The “Advanced Recipient Selection” dialog box will appear. In this dialog box, you can enter your 
search query (see chapter 3 Search Engine of MoCo User Manual), and then click “Search” button to retrieve 
the search result. For example as shown below, you can target your SMS recipients to be males who are between 
30 to 40 years old. 
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Step 7: Upon clicking the “Search” button, the result shall be displayed on the lower portion of the dialog box.  
 

 
 
Step 8: Click “Select All” button to select all the contacts retrieved from the search. You can also select a few of 
the contacts by pressing “Ctrl” key and click on their individual names, then click “Selected Contacts” button. 
 
Step 9: Click “Send” button to send the SMS. 
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Chapter 6: Create a Marketing Campaign 
 
MoCo’s Campaign Manager allows user to create SMS campaigns such as voting, contest or survey. With 
Campaign Manager, you can create your own e-campaign to consolidate sms feedbacks or surveys in the form 
of graphical representation. 
 
 
 

 
 
 

6.1 Add new Campaign 
 
To add a new campaign,  
 

Step 1: Click on  button to clear Campaign information area. 
 
Step 2: Enter campaign information into respective fields.  
 

 
 

• Campaign Name – Enter a name for the campaign 
• Campaign Description – Text description on the campaign 
• Available Options – Enter the acceptable code names (Eg. B1, B2, B3, B4) for the campaign. Each 

code name represent a particular selection, in this case for the Beverage Survey, B1 represent Green 
Tea, B2 represent Red Tea, etc. 

 

 - 16 - 



Step 3: Click on  to save the campaign. 
 
When a campaign is created successfully, the campaign name will appear on the List of Campaigns box. 
 

6.2 Delete Campaign 
 
To delete a campaign, 
 
Step 1: From the List of Campaigns box, select the campaign to be deleted by clicking on the campaign name. A 
blue highlight will appear. 
 

Step 2: Click on  to delete the highlighted campaign. 
 

6.3 Updating Campaign 
 
To update an campaign, 
 
Step 1: Select the campaign to be updated from the List of Campaigns box. 
 
Step 2: Replace the information to be updated. 
 

Step 3: Click on  to save the changed information. 
 

6.4 How it Works 

6.4.1 Create an ARS Rule 
  
After you have created a campaign using the Campaign Manager, the next thing to do is to create a rule for that 
campaign using the Automatic Response System. 
 

 
 
Following the example on the Beverage Survey, you can now go to the Automatic Response System page and 
create a new rule called “Beverage Survey” (or any other name you prefer).  
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Select “All” for the sender condition and “Begin with: Bev” as the message pattern condition, as shown in above 
screen shot. 
 
Select the “SMS Vote/Contest/Survey” action and key in “Beverage Survey” as the campaign name. Once all 
these information is keyed in, you can add the new rule to the system. 
 

6.4.2 Wait for incoming SMS 
 
Once you have created the campaign and its corresponding rule, the only thing you need to do is to wait for 
incoming sms.  
 
For example, the following message content would be considered as a valid vote for this campaign: 
“Bev B2” 
 
When MoCo received the above-mentioned sms, it would consider it as a valid vote for the campaign “Beverage 
Survey”, as a vote towards the option “Red Tea”. 
 

6.4.3 View Campaign Result 
 
To view the result of a particular campaign, 
 
Step 1: Select the campaign from the List of Campaigns box. 
 

Step 2: Click on  to view the result of the campaign. 
 
Step 3: A dialog box will appear, displaying the result of the campaign. 
 

 
 
 
The top portion of the dialog box will show the graphical representation of the campaign result. The lower 
portion will show the detailed information of each votes. 
 
 
 
 
 
 
 
 

 - 18 - 



Under the “Detailed Information”, a context box will appear if you right-click the mouse on any of the vote: 
 

 
 

• Flag as Valid – Select this option to flag this particular vote as a valid vote. 
• Flag as Invalid – Select this option to flag this particular vote as an invalid vote. 

 
The option “Ignore duplicated votes” can be used to ignore multiple votes on the same item from the same 
mobile phone number. This option is useful if one wishes to implement a one-man-one-vote system. 
 

 
 
To save the campaign result to a file, click the “Save Information to File” button. 
 

6.4.4 Making use of Campaign Result 
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Under “Summary Information”, you can right-click the mouse on any option name and a context box will 
appear. 
 

• Send SMS to All 
 

 
 
A dialog box as shown above will appear for you to send SMS to all the voters who have selected the 
option. 
 
• Select Winner 

 

 
 

A dialog box as shown above will appear for you to select winner(s) from a list of voters who selected the 
option.  
 
Simply enter the number of winners and click “Pick Winner” button to randomly select a winner(s). 
 
Upon selecting the winner, you can also send a message to the winner(s) by keying in the message and then 
clicking the “Send SMS to Winners” button. 
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Chapter 7: Other Features 

7.1 Label Printing 
 
MoCo allows user to perform label printing on standard label type 1029.  
 
To perform label printing, select “Print Label” from the File menu. A dialog box as shown below will appear. 
 

 
 
Step 1: Select the contact who you wish to print the label of. 
 
Step 2: Make sure the type of label is “Label No. 1029”. 
 
Step 3: Select the position within label for printing. Click “OK”. The below Print dialog box will appear. 
 

 
  
Step 4: Select the appropriate printer name. Click “Properties” button to set the paper size. 
 

 
 
Step 5: A dialog box as shown above will appear. Note that for different printer, a different kind of dialog will 
appear. 
 
Step 6: Go to Page Setup and set the Page Size to “A5”.  
 
Step 7: Click “OK”. You will return to the previous Print dialog box. 
 
Step 8: Click “OK” to proceed with the printing. 
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7.2 Receipt Printing 
 
MoCo allows user to perform receipt printing on ‘A5’ size paper.  
 
To perform receipt printing, select “Print Receipt” from the File menu. A dialog box as shown below will 
appear. 

 
 
Step 1: Enter the reference number of the account you want to print. 
 
Step 2: Click “OK”. The below Print dialog box will appear. 
 

 
  
 
Step 3: Select the appropriate printer name. Click “Properties” button to set the paper size. 
 

 
 
Step 4: A dialog box as shown above will appear. Note that for different printer, a different kind of dialog will 
appear. 
 
Step 5: Go to Page Setup and set the Page Size to “A5”.  
 
Step 6: Click “OK”. You will return to the previous Print dialog box. 
 
Step 7: Click “OK” to proceed with the printing. 
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7.3 Accounts System 
 
MoCo has a built-in Accounts System for user to perform some simple accounting tasks. 
 
To invoke the Accounts System, select “Accounts System” from the Tools menu. A dialog box as shown below 
will appear. 
 

 
 

7.3.1 Add New Transaction 
 
Step 1: Click “Add New Transaction” button. A dialog boz as shown below will appear. 
 

 
 

Step 2: Key in the accounts information. For expenses, you can add a minus sign in front of the Amount Paid 
value. 
 
Step 3: Click “Save” button to add the account. 
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7.3.2 Manage existing account items 
 

 
 
To manage existing account item, right-click on the item and a context menu will appear for the following 
options: 

• Modify – Select this option to modify the information of the account item. 
• Delete – Select this option to delete the account item.  
• Print Receipt – Select this option to print receipt for this account item. Remember to set the paper size 

as ‘A5’. 
 

7.3.3 Query Account System 
 

 
 
At the Display Options, select the query parameters and click “Search” button. The list of account items that 
satisfy the query parameters will be displayed, together with the calculated balances. 
 

7.3.4 Accounts Settings 
 

 
 
By clicking the Setttings button on the Accounts System dialog box, the above dialog box will appear. You can 
set the individual timings and click Save button. The timings shall affect the calculations of individual balances. 
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7.3.5 Save Accounts Sheet 
 
By clicking the “Save Account Sheet” button on the Accounts System dialog box, you can save the currently 
displayed account sheet to a HTML file.  
 
 

 - 25 - 


